john-bodley closed pull request #4524: [setup] Adding requirements.txt
URL: https://github.com/apache/incubator-superset/pull/4524
 
 
   

This is a PR merged from a forked repository.
As GitHub hides the original diff on merge, it is displayed below for
the sake of provenance:

As this is a foreign pull request (from a fork), the diff is supplied
below (as it won't show otherwise due to GitHub magic):

diff --git a/CONTRIBUTING.md b/CONTRIBUTING.md
index 3051d94fdc..09627b5163 100644
--- a/CONTRIBUTING.md
+++ b/CONTRIBUTING.md
@@ -49,7 +49,7 @@ If you are proposing a feature:
     implement.
 -   Remember that this is a volunteer-driven project, and that
     contributions are welcome :)
-    
+
 ### Questions
 
 There is a dedicated 
[tag](https://stackoverflow.com/questions/tagged/apache-superset) on 
[stackoverflow](https://stackoverflow.com/). Please use it when asking 
questions.
@@ -98,7 +98,7 @@ to manage the Python packages you're about to install:
     virtualenv superset-dev
     source superset-dev/bin/activate
 
-Finally, to make changes to the rst files and build the docs using Sphinx, 
+Finally, to make changes to the rst files and build the docs using Sphinx,
 you'll need to install a handful of dependencies from the repo you cloned:
 
     cd incubator-superset
@@ -177,6 +177,7 @@ Check the [OS 
dependencies](https://superset.incubator.apache.org/installation.h
     source env/bin/activate
 
     # install for development
+    pip install -r requirements.txt
     pip install -e .
 
     # Create an admin user
@@ -269,11 +270,11 @@ pip install -r dev-reqs.txt
 All python tests can be run with:
 
     ./run_tests.sh
-    
+
 Alternatively, you can run a specific test with:
 
     ./run_specific_test.sh tests.core_tests:CoreTests.test_function_name
-    
+
 Note that before running specific tests, you have to both setup the local 
testing environment and run all tests.
 
 We use [Mocha](https://mochajs.org/), [Chai](http://chaijs.com/) and 
[Enzyme](http://airbnb.io/enzyme/) to test Javascript. Tests can be run with:
@@ -297,7 +298,7 @@ Codeclimate is a service we use to measure code quality and 
test coverage. To ge
 
 *Install the codeclimate cli tool*
 ```
-curl -L 
https://github.com/docker/machine/releases/download/v0.7.0/docker-machine-`uname
 -s`-`uname -m` > /usr/local/bin/docker-machine && chmod +x 
/usr/local/bin/docker-machine 
+curl -L 
https://github.com/docker/machine/releases/download/v0.7.0/docker-machine-`uname
 -s`-`uname -m` > /usr/local/bin/docker-machine && chmod +x 
/usr/local/bin/docker-machine
 brew install docker
 docker-machine create --driver virtual box default
 docker-machine env default
@@ -428,7 +429,7 @@ https://github.com/apache/incubator-superset/pull/3013
 
     # copy
     cp -r /tmp/tmp_superset_docs/ ~/incubator-superset-site.git/
- 
+
     # commit and push to `asf-site` branch
     cd ~/incubator-superset-site.git/
     git checkout asf-site
diff --git a/dev-reqs.txt b/dev-reqs.txt
index 91a74d6a44..3b69ffdc96 100644
--- a/dev-reqs.txt
+++ b/dev-reqs.txt
@@ -6,6 +6,7 @@ ipdb
 mock
 mysqlclient
 nose
+pip-tools
 psycopg2
 pylint
 pyyaml
diff --git a/requirements.txt b/requirements.txt
new file mode 100644
index 0000000000..8c3010582f
--- /dev/null
+++ b/requirements.txt
@@ -0,0 +1,39 @@
+bleach==2.1.2
+boto3==1.4.7
+celery==4.1.0
+colorama==0.3.9
+cryptography==1.9
+flask==0.12.2
+flask-appbuilder==1.9.6
+flask-cache==0.13.1
+flask-migrate==2.1.1
+flask-script==2.0.6
+flask-sqlalchemy==2.1
+flask-testing==0.7.1
+flask-wtf==0.14.2
+flower==0.9.2
+future==0.16.0
+geopy==1.11.0
+gunicorn==19.7.1
+humanize==0.5.1
+idna==2.6
+markdown==2.6.11
+pandas==0.22.0
+parsedatetime==2.0.0
+pathlib2==2.3.0
+polyline==1.3.2
+pydruid==0.4.1
+pyhive==0.5.0
+python-dateutil==2.6.1
+python-geohash==0.8.5
+pyyaml==3.12
+requests==2.18.4
+simplejson==3.13.2
+six==1.11.0
+sqlalchemy==1.2.2
+sqlalchemy-utils==0.32.21
+sqlparse==0.2.4
+thrift==0.11.0
+thrift-sasl==0.3.0
+unicodecsv==0.14.1
+unidecode==1.0.22
diff --git a/setup.py b/setup.py
index c32696e698..24a01536c2 100644
--- a/setup.py
+++ b/setup.py
@@ -50,48 +50,48 @@ def get_git_sha():
     zip_safe=False,
     scripts=['superset/bin/superset'],
     install_requires=[
+        'bleach',
         'boto3>=1.4.6',
-        'celery==4.1.0',
-        'colorama==0.3.9',
-        'cryptography==1.9',
-        'flask==0.12.2',
-        'flask-appbuilder==1.9.6',
-        'flask-cache==0.13.1',
-        'flask-migrate==2.1.1',
-        'flask-script==2.0.6',
-        'flask-sqlalchemy==2.1',
-        'flask-testing==0.7.1',
-        'flask-wtf==0.14.2',
-        'flower==0.9.2',
+        'celery',
+        'colorama',
+        'cryptography',
+        'flask',
+        'flask-appbuilder',
+        'flask-cache',
+        'flask-migrate',
+        'flask-script',
+        'flask-sqlalchemy',
+        'flask-testing',
+        'flask-wtf',
+        'flower',
         'future>=0.16.0, <0.17',
-        'geopy==1.11.0',
-        'python-geohash==0.8.5',
-        'humanize==0.5.1',
-        'gunicorn==19.7.1',
-        'idna==2.6',
-        'markdown==2.6.11',
-        'pandas==0.22.0',
-        'parsedatetime==2.0.0',
-        'pathlib2==2.3.0',
-        'polyline==1.3.2',
-        'pydruid==0.4.1',
-        'PyHive>=0.4.0',
-        'python-dateutil==2.6.1',
+        'geopy',
+        'gunicorn',
+        'humanize',
+        'idna',
+        'markdown',
+        'pandas',
+        'parsedatetime',
+        'pathlib2',
+        'polyline',
+        'pydruid',
+        'pyhive>=0.4.0',
+        'python-dateutil',
+        'python-geohash',
         'pyyaml>=3.11',
-        'requests==2.18.4',
-        'simplejson==3.13.2',
-        'six==1.11.0',
-        'sqlalchemy==1.2.2',
-        'sqlalchemy-utils==0.32.21',
-        'sqlparse==0.2.4',
+        'requests',
+        'simplejson',
+        'six',
+        'sqlalchemy',
+        'sqlalchemy-utils',
+        'sqlparse',
         'thrift>=0.9.3',
         'thrift-sasl>=0.2.1',
+        'unicodecsv',
         'unidecode>=0.04.21',
-        'unicodecsv==0.14.1',
-        'bleach==2.1.2',
     ],
     extras_require={
-        'cors': ['Flask-Cors>=2.0.0'],
+        'cors': ['flask-cors>=2.0.0'],
     },
     tests_require=[
         'codeclimate-test-reporter',
diff --git a/tox.ini b/tox.ini
index 280bcb4798..4ed9bc9e47 100644
--- a/tox.ini
+++ b/tox.ini
@@ -38,6 +38,7 @@ find_links =
 
 [testenv]
 deps =
+    -rrequirements.txt
     wheel
     coveralls
 whitelist_externals =


 

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
us...@infra.apache.org


With regards,
Apache Git Services

Reply via email to