pitipund opened a new issue #4783: error when export datasources 
URL: https://github.com/apache/incubator-superset/issues/4783
 
 
   Make sure these boxes are checked before submitting your issue - thank you!
   
   - [x] I have checked the superset logs for python stacktraces and included 
it here as text if any
   - [x] I have reproduced the issue with at least the latest released version 
of superset
   - [x] I have checked the issue tracker for the same issue and I haven't 
found one similar
   
   
   ### Superset version
   0.24.0
   
   ### Expected results
   create the yaml file successful
   
   ### Actual results
   $ superset export_datasources
   2018-04-08 17:18:57,891:INFO:root:Starting export
   Traceback (most recent call last):
     File "/home/xxx/.virtualenvs/yyy/bin/superset", line 15, in <module>
       manager.run()
     File 
"/home/xxx/.virtualenvs/yyy/lib/python3.5/site-packages/flask_script/__init__.py",
 line 417, in run
       result = self.handle(argv[0], argv[1:])
     File 
"/home/xxx/.virtualenvs/yyy/lib/python3.5/site-packages/flask_script/__init__.py",
 line 386, in handle
       res = handle(*args, **config)
     File 
"/home/xxx/.virtualenvs/yyy/lib/python3.5/site-packages/flask_script/commands.py",
 line 216, in __call__
       return self.run(*args, **kwargs)
     File 
"/home/xxx/.virtualenvs/yyy/lib/python3.5/site-packages/superset/cli.py", line 
251, in export_datasources
       include_defaults=include_defaults)
     File 
"/home/xxx/.virtualenvs/yyy/lib/python3.5/site-packages/superset/dict_import_export_util.py",
 line 40, in export_to_dict
       include_defaults=include_defaults) for database in dbs]
     File 
"/home/xxx/.virtualenvs/yyy/lib/python3.5/site-packages/superset/dict_import_export_util.py",
 line 40, in <listcomp>
       include_defaults=include_defaults) for database in dbs]
     File 
"/home/xxx/.virtualenvs/yyy/lib/python3.5/site-packages/superset/models/helpers.py",
 line 196, in export_to_dict
       key=lambda k: sorted(k.items()))
   TypeError: <flask_script.commands.Command object at 0x7f462a6a7128>: 
unorderable types: dict() < dict()
   
   
   ### Steps to reproduce
   1. Add the mssql datasource 
   2. Create the dashboard
   3. from command line , run "superset export_datasources" 
   
   

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
us...@infra.apache.org


With regards,
Apache Git Services

Reply via email to