Severity: important
Affected versions:
- Apache Syncope 3.0.0-M0 through 3.0.16
- Apache Syncope 4.0.0-M0 through 4.0.8
- Apache Syncope 4.1.0-M0 through 4.1.3
Description:
Improper neutralization of special elements used in an SQL command ('SQL
injection') vulnerability in Apache Syncope.
This CVE covers an incomplete fix for CVE-2026-77051: an administrator with
adequate entitlements can achieve execution of arbitrary SQL via stacked
queries, leveraging unsanitized opEvent parameters.
Reference: https://cve.org/CVERecord?id=CVE-2026-77051
This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0
through 4.0.8, from 4.1.0-M0 through 4.1.3.
Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue.
Credit:
Alex Palinkash (finder)
References:
https://syncope.apache.org/
https://www.cve.org/CVERecord?id=CVE-2026-114364