[ 
https://issues.apache.org/jira/browse/TIKA-2598?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16388297#comment-16388297
 ] 

Tim Allison commented on TIKA-2598:
-----------------------------------

This plugin turns up a bunch of others:

Dependency convergence error for org.hamcrest:hamcrest-core:1.3 paths to 
dependency are:
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-junit:junit:4.12
    +-org.hamcrest:hamcrest-core:1.3
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.mockito:mockito-core:1.7
    +-org.hamcrest:hamcrest-core:1.1

[WARNING] 
Dependency convergence error for com.google.guava:guava:17.0 paths to 
dependency are:
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-edu.ucar:cdm:4.5.5
    +-com.google.guava:guava:17.0
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.cleartk:cleartk-util:2.0.0
      +-com.google.guava:guava:17.0
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-com.google.guava:guava:10.0

[WARNING] 
Dependency convergence error for org.apache.opennlp:opennlp-tools:1.8.3 paths 
to dependency are:
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.opennlp:opennlp-tools:1.8.3
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.apache.opennlp:opennlp-tools:1.5.3

[WARNING] 
Dependency convergence error for org.apache.uima:uimaj-tools:2.6.0 paths to 
dependency are:
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.apache.ctakes:ctakes-utils:3.2.2
      +-org.apache.uima:uimaj-tools:2.6.0
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.apache.uima:uimaj-examples:2.4.0
      +-org.apache.uima:uimaj-tools:2.4.0

[WARNING] 
Dependency convergence error for org.apache.httpcomponents:httpcore:4.2.5 paths 
to dependency are:
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-edu.ucar:cdm:4.5.5
    +-org.apache.httpcomponents:httpcore:4.2.5
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-edu.ucar:httpservices:4.5.5
    +-org.apache.httpcomponents:httpcore:4.2.5
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.httpcomponents:httpclient:4.5.4
    +-org.apache.httpcomponents:httpcore:4.4.7

[WARNING] 
Dependency convergence error for org.jdom:jdom2:2.0.4 paths to dependency are:
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-edu.ucar:grib:4.5.5
    +-org.jdom:jdom2:2.0.4
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-edu.ucar:cdm:4.5.5
    +-org.jdom:jdom2:2.0.4
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.jdom:jdom2:2.0.3

[WARNING] 
Dependency convergence error for org.apache.tika:tika-core:2.0.0-SNAPSHOT paths 
to dependency are:
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.tika:tika-core:2.0.0-SNAPSHOT
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.tika:tika-core:2.0.0-SNAPSHOT
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.gagravarr:vorbis-java-tika:0.8
    +-org.apache.tika:tika-core:1.12

[WARNING] 
Dependency convergence error for com.github.jai-imageio:jai-imageio-core:1.3.1 
paths to dependency are:
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-com.github.jai-imageio:jai-imageio-core:1.3.1
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-com.github.jai-imageio:jai-imageio-jpeg2000:1.3.0
    +-com.github.jai-imageio:jai-imageio-core:1.3.0

[WARNING] 
Dependency convergence error for org.apache.uima:uimaj-core:2.4.0 paths to 
dependency are:
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.apache.ctakes:ctakes-type-system:3.2.2
      +-org.apache.uima:uimaj-core:2.4.0
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.apache.ctakes:ctakes-utils:3.2.2
      +-org.apache.uima:uimaj-core:2.4.0
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.apache.ctakes:ctakes-utils:3.2.2
      +-org.apache.uima:uimaj-tools:2.6.0
        +-org.apache.uima:uimaj-core:2.6.0
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.cleartk:cleartk-util:2.0.0
      +-org.apache.uima:uimaj-core:2.5.0
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.apache.uima:uimaj-examples:2.4.0
      +-org.apache.uima:uimaj-core:2.4.0
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.apache.uima:uimaj-examples:2.4.0
      +-org.apache.uima:uimaj-document-annotation:2.4.0
        +-org.apache.uima:uimaj-core:2.4.0

[WARNING] 
Dependency convergence error for org.apache.uima:uimafit-core:2.1.0 paths to 
dependency are:
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.apache.ctakes:ctakes-type-system:3.2.2
      +-org.apache.uima:uimafit-core:2.1.0
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.cleartk:cleartk-util:2.0.0
      +-org.apache.uima:uimafit-core:2.0.0
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.apache.uima:uimafit-core:2.1.0

[WARNING] 
Dependency convergence error for org.objenesis:objenesis:2.6 paths to 
dependency are:
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.commons:commons-compress:1.16.1
    +-org.objenesis:objenesis:2.6
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.mockito:mockito-core:1.7
    +-org.objenesis:objenesis:1.0

[WARNING] 
Dependency convergence error for org.apache.uima:uimaj-cpe:2.6.0 paths to 
dependency are:
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.apache.ctakes:ctakes-utils:3.2.2
      +-org.apache.uima:uimaj-tools:2.6.0
        +-org.apache.uima:uimaj-cpe:2.6.0
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.apache.uima:uimaj-examples:2.4.0
      +-org.apache.uima:uimaj-cpe:2.4.0

[WARNING] 
Dependency convergence error for commons-io:commons-io:2.5 paths to dependency 
are:
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-commons-io:commons-io:2.5
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-commons-io:commons-io:2.0.1
and
+-org.apache.tika:tika-parsers:2.0.0-SNAPSHOT
  +-org.apache.ctakes:ctakes-core:3.2.2
    +-org.cleartk:cleartk-util:2.0.0
      +-commons-io:commons-io:2.4

> Fix dependency convergence
> --------------------------
>
>                 Key: TIKA-2598
>                 URL: https://issues.apache.org/jira/browse/TIKA-2598
>             Project: Tika
>          Issue Type: Improvement
>          Components: packaging
>    Affects Versions: 1.17
>            Reporter: Guillaume Smet
>            Assignee: Tim Allison
>            Priority: Blocker
>
> Hi,
> We tried to upgrade Tika to 1.17 in Hibernate Search and we had some 
> dependency convergence issues:
> {code}
> Dependency convergence error for 
> com.healthmarketscience.jackcess:jackcess:2.1.8 paths to dependency are:
> +-org.hibernate:hibernate-search-engine:5.10.0-SNAPSHOT
>     +-org.apache.tika:tika-parsers:1.17
>          +-com.healthmarketscience.jackcess:jackcess:2.1.8
> and
> +-org.hibernate:hibernate-search-engine:5.10.0-SNAPSHOT
>      +-org.apache.tika:tika-parsers:1.17
>          +-com.healthmarketscience.jackcess:jackcess-encrypt:2.1.2
>              +-com.healthmarketscience.jackcess:jackcess:2.1.0
> {code}
> We could fix them downstream in Hibernate Search but I thought it would be 
> better if Tika could ensure the convergence of its dependencies using the 
> Maven enforcer plugin so that all the downstream projects can benefit from it.
> Thanks.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to