This is an automated email from the ASF dual-hosted git repository.

rmaucher pushed a change to branch 11.0.x
in repository https://gitbox.apache.org/repos/asf/tomcat.git


    from a0733659dc Remove unnecessary cast
     new 0270a8ade3 Add the missing standardService.connector.startFailed and 
standardService.connector.stopFailed localization keys so connector start and 
stop failures produce readable messages rather than the raw key
     new be639f85e9 Synchronise access to the StandardHost childClassLoaders 
map which is written by context start threads and read by 
findReloadedContextMemoryLeaks() from Manager/JMX threads, preventing 
concurrent modification of the underlying WeakHashMap during iteration
     new c8c7010e8c Delegate awaitTermination() in StandardThreadExecutor and 
StandardVirtualThreadExecutor to the wrapped executor rather than 
unconditionally returning false which violates the ExecutorService contract
     new 72c537bc9d Synchronise the check and assignment of the servlet 
instance in getServletMethods() to prevent a race which could result in a 
second, never initialised instance being retained by the wrapper
     new 947b2d0e53 Validate the incoming entry at the start of 
NamingResourcesImpl.addEnvironment() so that an entry which is ignored or 
rejected cannot first destroy the existing environment entry or resource link 
with the same name
     new e8bb9125a3 Retain an existing resource link in 
NamingResourcesImpl.addEnvironment() when the link's global target is not an 
overridable global environment rather than adding an environment entry with the 
same name which would create a duplicate JNDI binding
     new 4992bfb8ad Walk the class hierarchy in NamingResourcesImpl 
getSetterType() and getFieldType() so that injection targets resolving to 
inherited fields or setters are no longer rejected at deployment, matching the 
behaviour of the runtime injection engine
     new 0525d59f9d Only release the shared naming entry name in 
NamingResourcesImpl remove*() methods when the type-specific map actually held 
the entry, preventing the removal of the JNDI name reservation of a differently 
typed descriptor with the same name
     new c64102d2ac Use the atomic add() of the shared entries set as the name 
claim in all NamingResourcesImpl add*() methods to close the check-then-act 
race which could allow two descriptors with the same JNDI name to both be 
registered
     new 8119db0676 Merge branch '11.0.x' of [email protected]:apache/tomcat.git 
into 11.0.x

The 10 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 .../apache/catalina/core/LocalStrings.properties   |   2 +
 java/org/apache/catalina/core/StandardHost.java    |  19 ++-
 .../catalina/core/StandardThreadExecutor.java      |   6 +-
 .../core/StandardVirtualThreadExecutor.java        |   6 +-
 java/org/apache/catalina/core/StandardWrapper.java |   9 +-
 .../catalina/deploy/NamingResourcesImpl.java       | 189 ++++++++++++---------
 .../core/TestExecutorAwaitTermination.java         |  75 ++++++++
 7 files changed, 223 insertions(+), 83 deletions(-)
 create mode 100644 
test/org/apache/catalina/core/TestExecutorAwaitTermination.java


---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to