2012/6/7  <schu...@apache.org>:
> Author: schultz
> Date: Wed Jun  6 20:05:05 2012
> New Revision: 1347087
>
> URL: http://svn.apache.org/viewvc?rev=1347087&view=rev
> Log:
> Fix https://issues.apache.org/bugzilla/show_bug.cgi?id=53373
> Trim whitespace from around <Context> aliases delimiters (,=) to improve 
> readability of many aliases.
>
> Modified:
>    tomcat/trunk/java/org/apache/naming/resources/BaseDirContext.java
>    tomcat/trunk/test/org/apache/naming/resources/TestNamingContext.java
>    tomcat/trunk/webapps/docs/config/context.xml
>

> --- tomcat/trunk/test/org/apache/naming/resources/TestNamingContext.java 
> (original)
> +++ tomcat/trunk/test/org/apache/naming/resources/TestNamingContext.java Wed 
> Jun  6 20:05:05 2012
> @@ -16,6 +16,8 @@
>  */
>  package org.apache.naming.resources;
>
> +import java.io.File;
> +import java.io.FileOutputStream;
>  import java.io.IOException;
>  import java.io.PrintWriter;
>
> @@ -30,6 +32,8 @@ import javax.servlet.http.HttpServlet;
>  import javax.servlet.http.HttpServletRequest;
>  import javax.servlet.http.HttpServletResponse;
>
> +import junit.framework.Assert;
> +
>  import static org.junit.Assert.assertEquals;
>  import static org.junit.Assert.assertTrue;
>
> @@ -89,6 +93,142 @@ public class TestNamingContext extends T
>
>     }
>
> +    // Recursively deletes a directory and its contents
> +    private boolean rmdir(File dir)
> +    {

1. I usually write '{' on the same line, like in Java conventions.
Just personal preference. Not enforcing it, so no need to change.

2. Take a look at method
LoggingBaseTest#addDeleteOnTearDown(..)

That class is parent of TomcatBaseTest and method is specifically
designed to clean up temporary directories and files.

3. if(!mkdir() ) tests in the test method - I think if you rerun after
failed test those will return false, because directory already exists.

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@tomcat.apache.org
For additional commands, e-mail: dev-h...@tomcat.apache.org

Reply via email to