Marshall Schor commented on UIMA-5115:

I agree about readability.  What I was proposing was
1) this refactoring
2) (left unstated, sorry!) we can have whatever positional argument variations 
on these we want.  In particular, I completely agree that the 
coveredBy(boundingFs) reads very well, and should be one of the variants.

The point of the refactoring is to realize that you can have (more-or-less 
easily) other combinations, such as:  at(location).single(), with any of the 3 
variations of at, etc.

> uv3 select() api for iterators and streams over CAS contents
> ------------------------------------------------------------
>                 Key: UIMA-5115
>                 URL: https://issues.apache.org/jira/browse/UIMA-5115
>             Project: UIMA
>          Issue Type: New Feature
>          Components: Core Java Framework
>            Reporter: Marshall Schor
>            Priority: Minor
>             Fix For: 3.0.0SDKexp
> Design and implement a select() API based on uimaFIT's select, integrated 
> well with Java 8 concepts.  Initial discussions in UIMA-1524.  Wiki with 
> diagram: https://cwiki.apache.org/confluence/display/UIMA/UV3+Iterator+support

This message was sent by Atlassian JIRA

Reply via email to