Marshall Schor commented on UIMA-5115:

I agree it's nice to have 
 * coveredBy(sentence)
 * covering(10, 20)
 * sameBeginEnd(token)

There are other cases.  How would you write combinations that use between(fs1, 
fs2) and coveredBy() etc? 
 * coveredBy(between(fs1, fs2))  // or
 * coveredBy().between(fs1, fs2);  // the builder methods are only partially 
ordered, so you could put the between following coveredBy, if that made for 
better readability.

I don't have a strong preference, so I would be fine with making "between" an 
argument of the 3 styles of boundary use; it could easily translate into a 
equivalent begin / end (unless I'm missing something).

The at(...) has another purpose, besides setting a boundary - it can specify a 
starting position. Shall we keep "at" for that purpose (or rename it "startAt")?

> uv3 select() api for iterators and streams over CAS contents
> ------------------------------------------------------------
>                 Key: UIMA-5115
>                 URL: https://issues.apache.org/jira/browse/UIMA-5115
>             Project: UIMA
>          Issue Type: New Feature
>          Components: Core Java Framework
>            Reporter: Marshall Schor
>            Priority: Minor
>             Fix For: 3.0.0SDKexp
> Design and implement a select() API based on uimaFIT's select, integrated 
> well with Java 8 concepts.  Initial discussions in UIMA-1524.  Wiki with 
> diagram: https://cwiki.apache.org/confluence/display/UIMA/UV3+Iterator+support

This message was sent by Atlassian JIRA

Reply via email to