Marshall Schor commented on UIMA-5115:

Re: meaning of at(...)

Would you prefer at(...) be be reserved for the sameBeginEnd style of using 
bounds?  The other use of at (to provide a starting position) could be covered 
by renaming it to "startAt".

The other uses of at (to specify a bound) could be absorbed into the coveredBy 
and covering methods.

This would also eliminate the sameBeginEnd general style (it could only be 
applied with an "at" style bound (e.g., not with a "between" style bound).

> uv3 select() api for iterators and streams over CAS contents
> ------------------------------------------------------------
>                 Key: UIMA-5115
>                 URL: https://issues.apache.org/jira/browse/UIMA-5115
>             Project: UIMA
>          Issue Type: New Feature
>          Components: Core Java Framework
>            Reporter: Marshall Schor
>            Priority: Minor
>             Fix For: 3.0.0SDKexp
> Design and implement a select() API based on uimaFIT's select, integrated 
> well with Java 8 concepts.  Initial discussions in UIMA-1524.  Wiki with 
> diagram: https://cwiki.apache.org/confluence/display/UIMA/UV3+Iterator+support

This message was sent by Atlassian JIRA

Reply via email to