[ 
https://issues.apache.org/jira/browse/WEEX-90?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Adam Feng resolved WEEX-90.
---------------------------
    Resolution: Fixed

> Remove The Legacy Weex DSL 1.0 (.we) Front-End Framework
> --------------------------------------------------------
>
>                 Key: WEEX-90
>                 URL: https://issues.apache.org/jira/browse/WEEX-90
>             Project: Weex
>          Issue Type: Bug
>            Reporter: Hanks Zhang
>            Assignee: Adam Feng
>            Priority: Major
>
> Weex DSL 1.0 (.we) front-end framework is inspired by Vue.js 1.0. Since Weex 
> supports the official Vue.js 2.0 in v0.10.0 [1] at 2017-02-17, the ".we" 
> framework is deprecated. In order to optimize the performance, stability, and 
> package size, this legacy framework should be removed from the WeexSDK.
> I suggest removing the ".we" framework in the 2018 January release of WeexSDK.
> For the projects who are still using the ".we" framework, you can read the 
> "Migration From .we Framework" [2] and "The Syntax Difference Between .we and 
> .vue" [3] documents to help you migrate your ".we" project to Vue.js 2.0 
> project. But those documents only have Chinese version.
> [1] https://github.com/alibaba/weex/releases/tag/v0.10.0
> [2] http://weex-project.io/cn/references/migration/migration-from-weex.html
> [3] http://weex-project.io/cn/references/migration/difference.html



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to