Hi guys,
I have an Interface called FeatureManager. I want to have methods to
retrieve features for device type, device identifier and all features. Is
it consistent with our practice to name these methods as below -

   - getFeatures (String deviceType)
   - getFeatures (DeviceIdentifier deviceIdentifier)
   - getFeatures() - get all features

Or do you prefer it if the methods are not overloaded?

​Cheers~​

-- 
Dulitha Wijewantha (Chan)
Software Engineer - Mobile Development
WSO2 Inc
Lean.Enterprise.Middleware
 * ~Email       duli...@wso2.com <duli...@wso2mobile.com>*
*  ~Mobile     +94712112165*
*  ~Website   dulitha.me <http://dulitha.me>*
*  ~Twitter     @dulitharw <https://twitter.com/dulitharw>*
  *~Github     @dulichan <https://github.com/dulichan>*
  *~SO     @chan <http://stackoverflow.com/users/813471/chan>*
_______________________________________________
Dev mailing list
Dev@wso2.org
http://wso2.org/cgi-bin/mailman/listinfo/dev

Reply via email to