Hi Junior,

If the nodes are not clustered this cause because another node won't index
the artifacts. In a noncluster mode, you have to enable skipCache in
registry.xml.

Skip caching by adding the following configuration under the
<indexingConfiguration> element in the
<API-M_HOME>/repository/conf/registry.xml file in all Publisher and Store
nodes.

This helps to avoid facing caching related issues in the Store and
Publisher nodes by directly getting the API information from the database.
<skipCache>true</skipCache>

Thanks,
Harsha
On Wed, Aug 9, 2017 at 7:45 AM, Júnior <fjunio...@gmail.com> wrote:

> Hi Everyone,
>
> I have the following setup:
>
> 2 API Manager instances not clustered sharing the same DB. The only thing
> that is not shared is the Local Registry.
>
> We are able to use the import/export tool to import the API.
>
> And be able to see the APIs in store in both servers.
>
> But if I publish in one server, it doesn't show as published in the other
> server.
>
> Could it be related to the cache in the registry mount?
>
> Does anyone has any clue about this?
>
> Thanks,
>
> --
> Francisco Ribeiro
> *SCEA|SCJP|SCWCD|IBM Certified SOA Associate*
>
> _______________________________________________
> Dev mailing list
> Dev@wso2.org
> http://wso2.org/cgi-bin/mailman/listinfo/dev
>
>


-- 
Harsha Kumara
Software Engineer, WSO2 Inc.
Mobile: +94775505618
Blog:harshcreationz.blogspot.com
_______________________________________________
Dev mailing list
Dev@wso2.org
http://wso2.org/cgi-bin/mailman/listinfo/dev

Reply via email to