GitHub user ReedOei opened a pull request:

    [ZEPPELIN-3399] Tests failing with no changes - ShellScriptLauncherTest and 

    ### What is this PR for?
    When I run all of the tests zeppelin-zengine in IntelliJ, the tests in 
ShellScriptLauncherTest and SparkInterpreterLaunchTest fail, but if I run these 
tests by themselves, they pass.
    There is a problem with the tests in ShellScripterLauncherTest and 
SparkInterpreterLaunchTest, which is that if some of the ConfVars are set (such 
as ZEPPELIN_HOME) in other tests, then these tests will fail, because they 
expect that these variables are not set. 
    To fix this, I have added a setUp() method that clears all of the ConfVars 
to both ShellScripterLauncherTest and SparkInterpreterLauncherTest. This way, 
none of the ConfVars will be set when these tests are run.
    ### What type of PR is it?
    Bug Fix for tests ShellScripterLauncherTest and 
    ### What is the Jira issue?
    ### How should this be tested?
    Can verify tests still work after pull request by running them, and can 
verify that they failed before by running all tests in IntelliJ in the default 
order that IntelliJ runs them.

You can merge this pull request into a Git repository by running:

    $ git pull 

Alternatively you can review and apply these changes as the patch at:

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #2918
commit ac9ff3b645f4ef79a598a14b910abb5892fe0216
Author: Reed Oei <oei.reed@...>
Date:   2018-04-06T20:59:00Z

    Fixed test: ShellScripterLauncherTest.testLauncher.

commit 49cb8d7142ecb5502535e4b294a5263522274e57
Author: Reed Oei <oei.reed@...>
Date:   2018-04-10T15:02:42Z

    Fixed tests in SparkInterpreterLauncherTest.



Reply via email to