[ 
https://issues.apache.org/jira/browse/ZOOKEEPER-1887?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13910489#comment-13910489
 ] 

Raul Gutierrez Segales commented on ZOOKEEPER-1887:
---------------------------------------------------

Heads-up for reviewers. I think there are two things I might want to change:

* instead of just being able to remove a watcher via its watcher_fn, we might 
want to support removing by the (watcher_fn, context) tuple as well. Does it 
sound useful?

* watcher_registration_t and watcher_deregistration_t are similar enough that 
we could have a union call watcher_action_t of those two and consolidate all 
the methods that manipulate them (i.e.: creating a {,de}registration, 
activating, deactivating and destroying). It'll reduce a bit the similar code 
and perhaps make it a bit more readable. But I'll wait for feedback before 
making this change. 

> C implementation of removeWatches
> ---------------------------------
>
>                 Key: ZOOKEEPER-1887
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1887
>             Project: ZooKeeper
>          Issue Type: New Feature
>          Components: c client
>            Reporter: Raul Gutierrez Segales
>            Assignee: Raul Gutierrez Segales
>             Fix For: 3.5.0
>
>         Attachments: ZOOKEEPER-1887.patch, ZOOKEEPER-1887.patch
>
>
> This is equivalent for ZOOKEEPER-442's Java impl. 



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Reply via email to