See https://builds.apache.org/job/ZooKeeper-trunk/3488/

###################################################################################
########################## LAST 60 LINES OF THE CONSOLE 
###########################
[...truncated 65.25 MB...]
     [exec] Log Message Received: [2017-08-06 
23:30:53,828:31895(0x2b16444e3540):ZOO_INFO@log_env@1096: Client 
environment:user.home=/home/jenkins]
     [exec] Log Message Received: [2017-08-06 
23:30:53,828:31895(0x2b16444e3540):ZOO_INFO@log_env@1108: Client 
environment:user.dir=/home/jenkins/jenkins-slave/workspace/ZooKeeper-trunk/build/test/test-cppunit]
     [exec] Log Message Received: [2017-08-06 
23:30:53,828:31895(0x2b16444e3540):ZOO_INFO@zookeeper_init_internal@1151: 
Initiating client connection, host=127.0.0.1:22181 sessionTimeout=10000 
watcher=0x461d20 sessionId=0 sessionPasswd=<null> context=0x7ffc030e6d40 
flags=0]
     [exec] Log Message Received: [2017-08-06 
23:30:53,828:31895(0x2b1646544700):ZOO_INFO@check_events@2424: initiated 
connection to server [127.0.0.1:22181]]
     [exec] Log Message Received: [2017-08-06 
23:30:53,848:31895(0x2b1646544700):ZOO_INFO@check_events@2476: session 
establishment complete on server [127.0.0.1:22181], 
sessionId=0x100a688e2c2000f, negotiated timeout=10000 ]
     [exec]  : elapsed 1001 : OK
     [exec] Zookeeper_simpleSystem::testAsyncWatcherAutoReset ZooKeeper server 
started : elapsed 10264 : OK
     [exec] Zookeeper_simpleSystem::testDeserializeString : elapsed 0 : OK
     [exec] Zookeeper_simpleSystem::testFirstServerDown : elapsed 1001 : OK
     [exec] Zookeeper_simpleSystem::testNullData : elapsed 1047 : OK
     [exec] Zookeeper_simpleSystem::testIPV6 : elapsed 1016 : OK
     [exec] Zookeeper_simpleSystem::testCreate : elapsed 1024 : OK
     [exec] Zookeeper_simpleSystem::testPath : elapsed 1050 : OK
     [exec] Zookeeper_simpleSystem::testPathValidation : elapsed 1157 : OK
     [exec] Zookeeper_simpleSystem::testPing : elapsed 17635 : OK
     [exec] Zookeeper_simpleSystem::testAcl : elapsed 1029 : OK
     [exec] Zookeeper_simpleSystem::testChroot : elapsed 3106 : OK
     [exec] Zookeeper_simpleSystem::testAuth ZooKeeper server started ZooKeeper 
server started : elapsed 30552 : OK
     [exec] Zookeeper_simpleSystem::testHangingClient : elapsed 1051 : OK
     [exec] Zookeeper_simpleSystem::testWatcherAutoResetWithGlobal ZooKeeper 
server started ZooKeeper server started ZooKeeper server started : elapsed 
14947 : OK
     [exec] Zookeeper_simpleSystem::testWatcherAutoResetWithLocal ZooKeeper 
server started ZooKeeper server started ZooKeeper server started : elapsed 
14976 : OK
     [exec] Zookeeper_simpleSystem::testGetChildren2 : elapsed 1057 : OK
     [exec] Zookeeper_simpleSystem::testLastZxid : elapsed 4534 : OK
     [exec] Zookeeper_simpleSystem::testRemoveWatchers ZooKeeper server started 
: elapsed 4321 : OK
     [exec] *** Error in `./zktest-mt': corrupted double-linked list: 
0x0000000001b98810 ***
     [exec] /bin/bash: line 5: 31895 Aborted                 
ZKROOT=/home/jenkins/jenkins-slave/workspace/ZooKeeper-trunk/src/c/../.. 
CLASSPATH=$CLASSPATH:$CLOVER_HOME/lib/clover.jar ${dir}$tst
     [exec] Zookeeper_readOnly::testReadOnly : elapsed 4094 : OK
     [exec] OK (74)
     [exec] FAIL: zktest-mt
     [exec] ==========================================
     [exec] 1 of 2 tests failed
     [exec] Please report to u...@zookeeper.apache.org
     [exec] ==========================================
     [exec] make[1]: Leaving directory 
`/home/jenkins/jenkins-slave/workspace/ZooKeeper-trunk/build/test/test-cppunit'
     [exec] make[1]: *** [check-TESTS] Error 1
     [exec] make: *** [check-am] Error 2

BUILD FAILED
/home/jenkins/jenkins-slave/workspace/ZooKeeper-trunk/build.xml:1339: The 
following error occurred while executing this line:
/home/jenkins/jenkins-slave/workspace/ZooKeeper-trunk/build.xml:1299: The 
following error occurred while executing this line:
/home/jenkins/jenkins-slave/workspace/ZooKeeper-trunk/build.xml:1309: exec 
returned: 2

Total time: 16 minutes 24 seconds
Build step 'Execute shell' marked build as failure
[FINDBUGS] Skipping publisher since build result is FAILURE
[WARNINGS] Skipping publisher since build result is FAILURE
Archiving artifacts
Setting JDK_1_7_LATEST__HOME=/home/jenkins/tools/java/latest1.7
Recording fingerprints
Setting JDK_1_7_LATEST__HOME=/home/jenkins/tools/java/latest1.7
Recording test results
Setting JDK_1_7_LATEST__HOME=/home/jenkins/tools/java/latest1.7
Publishing Javadoc
Setting JDK_1_7_LATEST__HOME=/home/jenkins/tools/java/latest1.7
Setting JDK_1_7_LATEST__HOME=/home/jenkins/tools/java/latest1.7
Email was triggered for: Failure - Any
Sending email for trigger: Failure - Any
Setting JDK_1_7_LATEST__HOME=/home/jenkins/tools/java/latest1.7
Setting JDK_1_7_LATEST__HOME=/home/jenkins/tools/java/latest1.7



###################################################################################
############################## FAILED TESTS (if any) 
##############################
All tests passed

Reply via email to