[ 
https://issues.apache.org/jira/browse/ZOOKEEPER-3002?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16438381#comment-16438381
 ] 

ASF GitHub Bot commented on ZOOKEEPER-3002:
-------------------------------------------

GitHub user nkalmar opened a pull request:

    https://github.com/apache/zookeeper/pull/502

    ZOOKEEPER-3002 upgrade to jdk 8

    Set minimum requirement to java 1.8
    The code successfully compiled with 8.0.161-oracle and 8.0.163-zulu.
    
    Checking the generated class file it reports 1.8 as version:
    javap -verbose build/classes/org/apache/zookeeper/server/ServerStats.class 
| grep version
    minor version: 0
    major version: 52

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/nkalmar/zookeeper ZOOKEEPER-3002_java1.8

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/zookeeper/pull/502.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #502
    
----
commit 9878706c1157ed7442a7f2a4d623b4c68dbff601
Author: Norbert Kalmar <nkalmar@...>
Date:   2018-04-14T15:01:27Z

    ZOOKEEPER-3002 upgrade to jdk 8

----


> Upgrade branches 3.5 and trunk to Java 1.8
> ------------------------------------------
>
>                 Key: ZOOKEEPER-3002
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-3002
>             Project: ZooKeeper
>          Issue Type: Task
>          Components: java client, server
>    Affects Versions: 3.5.4, 3.6.0
>            Reporter: Andor Molnar
>            Assignee: Norbert Kalmar
>            Priority: Major
>              Labels: java1.8, upgrade
>             Fix For: 3.5.4, 3.6.0
>
>
> We upgrade the minimum required Java version to compile and run ZooKeeper on 
> 3.5 and master branches to Java 1.8.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to