Hello Tao,

I noticed these compile bugs:


commit 12dbb5b41008 ("Let crash change gdb context"):

  ../../crash_target.c: In member function ‘virtual void crash_target::fetch_registers(regcache*, int)’:
  ../../crash_target.c:86:30: error: ‘cpu’ was not declared in this scope
     86 |       if (crash_get_cpu_reg (cpu, r, regname, regsize, (void *)&regval))
        | ^~~


    Due to this change, `cpu` variable is not defined which is used later in the function.

        -  int cpu = inferior_ptid.tid();

    For now, I think we can keep it, and later keep this line, and then later remove it in the patch which renames crash_get_cpu_reg to remove 'cpu' argument.


commit 96531096efb4 ("Rename get_cpu_reg to get_current_task_reg"):

  x86_64.c: In function ‘x86_64_init’:
  x86_64.c:198:24: error: ‘struct machdep_table’ has no member named ‘get_cpu_reg’
    198 |                 machdep->get_cpu_reg = x86_64_get_cpu_reg;
        | ^~

    Just renaming 'get_cpu_reg' didn't help here, as 'x86_64_get_cpu_reg' is renamed later in separate patch.

    Maybe for this patch, temporarily this line can just be removed... but issue will be, x86_64 unwinding won't be supported from this patch till the patch renaming 'x86_64_get_cpu_reg'


Will continue with testing unwinding with vmcores.


Thanks,

Aditya Gupta

--
Crash-utility mailing list -- devel@lists.crash-utility.osci.io
To unsubscribe send an email to devel-le...@lists.crash-utility.osci.io
https://${domain_name}/admin/lists/devel.lists.crash-utility.osci.io/
Contribution Guidelines: https://github.com/crash-utility/crash/wiki

Reply via email to