On Thu, 01 Dec 2016 11:32:33 -0800
Howard Howell <hlhow...@pacbell.net> wrote:

> Hi, everyone,
>       I have been trying to upgrade my system from f24 to f25 using
> the cli in the terminal.
>   814  dnf system-upgrade download --releasever=25
>   815  dnf system-upgrade download --releasever=25 --allowerasing
>   816  dnf system-upgrade download --releasever=25 --allowerasing --
> nogpgcheck
>   all run from superuser.
>   error: 
> Running transaction check
> Transaction check succeeded.
> Running transaction test
> The downloaded packages were saved in cache until the next successful
> transaction.
> You can remove cached packages by executing 'dnf clean packages'.
> Error: Transaction check error:
>   file /usr/bin from install of
> google-earth-stable- conflicts with file from
> package filesystem-3.2-37.fc24.x86_64 # dnf --system-upgrade reboot
> will not run due to same error.

This is a well known error in the spec file for the google earth file.
It tries to own /usr/bin, which it can't own, and so fails.

Here's a web reference to it.
and here

A long time ago I installed google earth, and used a work around on the
spec file.  I don't remember it now, but it worked with the rebuilt rpm

The way to fix this so you can upgrade is by removing only google
earth using rpm directly, instead of through dnf.

rpm --erase --nodeps --test [google-earth-stable?]

This will test the command without doing anything.  When it does what
you want, remove the --test option.

After the upgrade, you can look for ways to re-install google earth.
devel mailing list -- devel@lists.fedoraproject.org
To unsubscribe send an email to devel-le...@lists.fedoraproject.org

Reply via email to