On Thu, 2016-12-01 at 14:52 -0800, Adam Williamson wrote:
> On Thu, 2016-12-01 at 17:03 -0500, Przemek Klosowski wrote:
> > This got me thinking if there's a common root cause that could be 
> > checked automatically? I didn't quite understand what exactly
> > happened 
> > in the affected packages to cause it.
> No, they're usually all different little awkward packaging corner
> cases.
> For instance, one common one in the F24 -> F25 upgrade involved the
> rpm
> python subpackages. These were called rpm-python and rpm-python3 in
> F24, but in F25 they were renamed to python2-rpm and python3-rpm . Of
> course, the F25 packages got lines like:
> Obsoletes: rpm-python < %{version}-%{release}
> Provides: rpm-python = %{version}-%{release}
> Obsoletes: rpm-python3 < %{version}-%{release}
> Provides: rpm-python3 = %{version}-%{release}
> Unfortunately, the F24 stable 'rpm' package actually got *ahead* of
> the
> F25 stable rpm package for a while. So when you tried to run the
> upgrade, the obsoletion didn't kick in - because the F24 package
> *wasn't* "< %{version}-%{release}". But dnf couldn't keep the old
> rpm-
> python(3) package(s) around because then some other dependency chain
> wasn't satisfied (I forget the details). So it simply had no way to
> resolve the problem without removing everything that required rpm-
> python or rpm-python3 ...
> But that's just one possible case, there have been many others.
> Packaging is hard. You can usually figure it out, if you dig into a
> bit; it *does* help to file bugs so the issues can be solved for
> others.
The rpm -e did in fact fix the issue.  The completeness solution posted
by John (I think that was who posted it) was a good idea.  However as
was pointed out, the package for Google-earth still has some issues.  I
need it to continue the development of the friends program, so I re-
installed it using dnf, and got the following error:
# dnf install google-earth
Last metadata expiration check: 0:46:41 ago on Thu Dec  1 15:46:43
Dependencies resolved.
 Package                  Arch        Version           Repository     
 google-earth-stable      x86_64      google-
earth       30 M

Transaction Summary
Install  1 Package

Total download size: 30 M
Installed size: 92 M
Is this ok [y/N]: y
Downloading Packages:
google-earth-stable-     356 kB/s |  30
MB     01:27    
Total                                           356 kB/s |  30
MB     01:27     
warning: /var/cache/dnf/google-earth-17f28a61f303b7a2/packages/google-
earth-stable- Header V4 DSA/SHA1 Signature, key
ID 7fac5991: NOKEY
The downloaded packages were saved in cache until the next successful
You can remove cached packages by executing 'dnf clean packages'.
Error: Public key for google-earth-stable- is
not installed

Still some work to do.  Is there any thing specific you believe I
should say in the bugzilla post?

Les H
devel mailing list -- devel@lists.fedoraproject.org
To unsubscribe send an email to devel-le...@lists.fedoraproject.org

Reply via email to