Worked great.

Test 1, C2 as sender, channel 1, B4 as receiver, C2 copy-nand'd from
os757.img, broadcast update worked fine, only three lost packets, and
that was as I was handling the receiving unit.  On the next run through
the sequence numbers the missing packets were picked up, the NAND was
updated, and the B4 booted normally, and did first-boot sugar name

Test 2, same C2 as sender, but restarted, four C2 units as receiver, all
receivers started first, then sender started.  Three units captured the
whole stream in two passes, wrote NAND.  One unit stalled with this on

ok enand1
Boot device: /dropin-fs:mcastnand  Arguments: ether: 1 /nandflash
Waiting for server
Expecting 2389 blocks, 236511 total packets (99 ppb)
0000 need 24
0002 need 12

(where _ represents the block cursor)

It did not budge despite (a) the sender cycling through block 3 again,
and (b) the unit being moved right next to the sender.

No keyboard input did anything.

I power cycled, and did the enand1 again, and it worked fine.

Can Q2E22A be used on B2?  ;-)

General comment ... starting an enand1 while a broadcast is already in
progress ... seems to generate two three "need" responses.  Tried this
five times.  Feels like a settling issue.  You did mention it.  It makes
a single-pass problematic, but since the sender loops, no biggie.

James Cameron    mailto:[EMAIL PROTECTED]
Devel mailing list

Reply via email to