mitch wrote:
 > >
 > > My XO Boots but gets stuck loading the initrd.
 > >
 > > OFW Q2E34
 > >
 > > Here is what I see on the screen
 > >
 > > Boot device: /nandflash:\boot\olpc.fth Arguments:
 > > Boot device: /nandflash:\boot\vmlinuz0 Arguments: root=mtd0 
 > > rootfstype=jffs2
 > > liveimg console=tty0 console=ttyS0,115200 boot_delay=3 fbcon=font:SUN12x22
 > > Loading ramdisk image from nand:\boot\initrd0.img
 > >
 > > It stays there its been about 20 minutes now.
 > >
 > >
 > >   
 > 
 > Try booting with the check button (game key above the power button) held 
 > down.
 > 
 > If that fixes the problem, the issues is that the OS is not switching 
 > from "pretty boot" mode to active screen mode.

i only realized recently that the final unfreeze of the screen
is not done in bootanim, as i expected, but by way of sugar installing
a g_idle callback that sends a message to ohmd to do the unfreeze.  so
if either sugar or ohmd don't start correctly, the screen will stay
frozen.  this doesn't seem optimal to me.  (and it may be that i have
it wrong, and there's another unfreeze mechanism as well.)

(when powerd replaces ohmd, it simply does the unfreeze after 10 seconds
have passed.  also sub-optimal.)

paul

 > 
 > You can disable pretty-boot by adding these lines to /boot/olpc.fth :
 > 
 >    unfreeze visible
 > 
 > The second line, just after the comment line, is a good place for them.
 > 
 > _______________________________________________
 > Sugar-devel mailing list
 > sugar-de...@lists.sugarlabs.org
 > http://lists.sugarlabs.org/listinfo/sugar-devel

=---------------------
 paul fox, p...@laptop.org
_______________________________________________
Devel mailing list
Devel@lists.laptop.org
http://lists.laptop.org/listinfo/devel

Reply via email to