Hi Steven,

Testing on XO-1 CL1.

On 11 Dec 2009, at 18:55, Steven M. Parrish wrote:

> If you are going to try out OS10 for the XO-1 here are a few things that need 
> testing.
> 
> Does it boot consistently into Sugar?  Gnome?

Yes, but only tested over a few reboot cycles for each.

> Any strange lockups?  If so what were you doing?

- Trackpad and keyboard stop working after letting XO to go into sleep. Power 
button wakes machine, backlight on, interface redraws, but no keyboard or 
mouse. Used power button to cycle sleeping/waking several times but no change. 
2 presses of power button to switch off and try again.

- Manually putting to sleep with the power button, same result. Interestingly, 
when the machine is asleep, moving the mouse or pressing keys does make the 
power led light up, but once machine is awake mouse and keys are dead again.

- Seemed to break after dcon freeze (you can usually see the screen briefly 
jump/glitch), wiggling the mouse right after the screen glitch but before the 
screen blanked still lost keyboard and mouse input (at least on two occasions).

> Can you upgrade packages using "yum update" from the command line?

- Yes, tested both an install of vim, then a general update.

> Does sound work?

- Yes, tested in TamTam, Speak, Pippy, Memorize, Record.

> Can you suspend?  Does it wake up?

- Yes, but with loss of keyboard and mouse as noted above.

> Please report any issues you have.

- For the majority of Activities I checked (Speak, Turtle Art, Moon, Memorize, 
Pippy, Read, Calculate, Labyrinth, Chat, Record, anything with the default 
Activity toolbar name/share/keep/stop), the Activity toolbar content now a tiny 
bit longer so that the Stop button is being pushed (by only a few pixels) into 
an overflow drop down menu :-( Did the gtk theme or widgets get tweaked, font 
size looks about right. Oddly enough I'm sure I disable the "Share with" widget 
in my Moon and Labyrinth activity code (as they don't yet support sharing), but 
they are now both showing the "Share with" widget in the toolbar, hmmmm....

- Record Activity only showing an audio tab, so can't test video or photo 
taking ability.

- Booting into Gnome does not recognise the XO battery and shows a "battery may 
be broken broken or very low charge" warning (I was originally running the XO 
from battery at about 50% charge remaining, but you get the same warning if on 
mains power).

- Still seeing two network device icons in bottom of the Sugar frame.

Regards,
--Gary
_______________________________________________
Devel mailing list
Devel@lists.laptop.org
http://lists.laptop.org/listinfo/devel

Reply via email to