Hello Peter,

On Thu, 2009-12-17 at 08:45 +0000, Peter Robinson wrote:
> On Wed, Dec 16, 2009 at 7:36 PM, C├ęsar D. Rodas
> <cro...@paraguayeduca.org> wrote:
> > Hi,
> >
> > The problem with the camera seems to be the xf86-video-geode package.
> > The cafe_ccic module is loaded automatically. Cheese and recordactivity
> > crashed right before show any picture. Then I tested remotely with ssh
> > -X and it worked for olpc and root user and it works.
> >
> > This test was done with:
> >
> >      * XO-1 kernel: 2.6.31_xo1-20091214.1334.1.olpc.49c30d0
> >      * os10
> >
> > Even if it works remotely, there are a lots of warning messages on
> > the /var/log/messages:
> 
> The gstreamer pipeline i used on the command line to take a photo is:
> 
> gst-launch-0.10 v4l2src ! ffmpegcolorspace ! pngenc ! filesink
> location=foo.png
It works perfectly fine, thanks for your help.

It seems to be that X is having a hard time displaying the video feed
for some reason I can't discover (yet). I took a look at
the /var/log/Xorg.0.log file (while attempting to run cheese) and it
said:

"Could not allocate memory for the video"

That's why it worked remotely before (apparently). I also tried loading
extra modules in xorg.conf (the ones that are loaded in the XO-1.5
config) but no go. 

I'm looking forward to read clues about how to fix it.

Regards,

> 
> It basically takes png file.
> 
> Regards,
> Peter
> 

_______________________________________________
Devel mailing list
Devel@lists.laptop.org
http://lists.laptop.org/listinfo/devel

Reply via email to