On 3/8/24 21:16, Rayhan Faizel wrote:
> Signed-off-by: Rayhan Faizel <rayhan.fai...@gmail.com>
> ---
>  src/qemu/qemu_capabilities.c                          | 2 ++
>  src/qemu/qemu_capabilities.h                          | 1 +
>  tests/qemucapabilitiesdata/caps_4.2.0_aarch64.xml     | 1 +
>  tests/qemucapabilitiesdata/caps_4.2.0_ppc64.xml       | 1 +
>  tests/qemucapabilitiesdata/caps_4.2.0_x86_64.xml      | 1 +
>  tests/qemucapabilitiesdata/caps_5.0.0_aarch64.xml     | 1 +
>  tests/qemucapabilitiesdata/caps_5.0.0_ppc64.xml       | 1 +
>  tests/qemucapabilitiesdata/caps_5.0.0_riscv64.xml     | 1 +
>  tests/qemucapabilitiesdata/caps_5.0.0_x86_64.xml      | 1 +
>  tests/qemucapabilitiesdata/caps_5.1.0_x86_64.xml      | 1 +
>  tests/qemucapabilitiesdata/caps_5.2.0_aarch64.xml     | 1 +
>  tests/qemucapabilitiesdata/caps_5.2.0_ppc64.xml       | 1 +
>  tests/qemucapabilitiesdata/caps_5.2.0_riscv64.xml     | 1 +
>  tests/qemucapabilitiesdata/caps_5.2.0_x86_64.xml      | 1 +
>  tests/qemucapabilitiesdata/caps_6.0.0_aarch64.xml     | 1 +
>  tests/qemucapabilitiesdata/caps_6.0.0_x86_64.xml      | 1 +
>  tests/qemucapabilitiesdata/caps_6.1.0_x86_64.xml      | 1 +
>  tests/qemucapabilitiesdata/caps_6.2.0_aarch64.xml     | 1 +
>  tests/qemucapabilitiesdata/caps_6.2.0_ppc64.xml       | 1 +
>  tests/qemucapabilitiesdata/caps_6.2.0_x86_64.xml      | 1 +
>  tests/qemucapabilitiesdata/caps_7.0.0_aarch64+hvf.xml | 1 +
>  tests/qemucapabilitiesdata/caps_7.0.0_aarch64.xml     | 1 +
>  tests/qemucapabilitiesdata/caps_7.0.0_ppc64.xml       | 1 +
>  tests/qemucapabilitiesdata/caps_7.0.0_x86_64.xml      | 1 +
>  tests/qemucapabilitiesdata/caps_7.1.0_ppc64.xml       | 1 +
>  tests/qemucapabilitiesdata/caps_7.1.0_x86_64.xml      | 1 +
>  tests/qemucapabilitiesdata/caps_7.2.0_ppc.xml         | 1 +
>  tests/qemucapabilitiesdata/caps_7.2.0_x86_64+hvf.xml  | 1 +
>  tests/qemucapabilitiesdata/caps_7.2.0_x86_64.xml      | 1 +
>  tests/qemucapabilitiesdata/caps_8.0.0_riscv64.xml     | 1 +
>  tests/qemucapabilitiesdata/caps_8.0.0_x86_64.xml      | 1 +
>  tests/qemucapabilitiesdata/caps_8.1.0_s390x.xml       | 1 +
>  tests/qemucapabilitiesdata/caps_8.1.0_x86_64.xml      | 1 +
>  tests/qemucapabilitiesdata/caps_8.2.0_aarch64.xml     | 1 +
>  tests/qemucapabilitiesdata/caps_8.2.0_s390x.xml       | 1 +
>  tests/qemucapabilitiesdata/caps_8.2.0_x86_64.xml      | 1 +
>  tests/qemucapabilitiesdata/caps_9.0.0_x86_64.xml      | 1 +
>  37 files changed, 38 insertions(+)
> 
> diff --git a/src/qemu/qemu_capabilities.c b/src/qemu/qemu_capabilities.c
> index ab11a929a3..7696756c3e 100644
> --- a/src/qemu/qemu_capabilities.c
> +++ b/src/qemu/qemu_capabilities.c
> @@ -704,6 +704,7 @@ VIR_ENUM_IMPL(virQEMUCaps,
>  
>                /* 455 */
>                "blockjob.backing-mask-protocol", /* 
> QEMU_CAPS_BLOCKJOB_BACKING_MASK_PROTOCOL */
> +              "mtp", /* QEMU_CAPS_DEVICE_MTP */

Nitpick, I'd name this "usb-mtp" and QEMU_CAPS_DEVICE_USB_MTP so that
it's obvious the corresponding device is "-device usb-mtp" and not just
"-device mtp". I'll do the necessary changes before pushing.

Michal
_______________________________________________
Devel mailing list -- devel@lists.libvirt.org
To unsubscribe send an email to devel-le...@lists.libvirt.org

Reply via email to