Just to follow up on this. I think I've got things working by 
recompiling kannel by hand rather than using the pre-built version 
available in the apt repo.

Now I just need to work out how to fix my old configuration file that 
used libmmsbox_mm1.so to use the new config options

On 18/08/14 17:46, Ben Hardill wrote:
> Hi,
> I'm trying to build and run Mbuni on a Raspberry Pi.
> I've installed the version of Kannel (v1.4.3-2) from the default 
> debian wheezy repo and it seams to be running fine.
> I've built Mbuni from the 1.6.0 tar or from cvs and when I run it I 
> get a SIGSEGV at startup. If I run it under gdb I get the following:
> root@ben-pi:~# gdb /usr/local/bin/mmsbox
> GNU gdb (GDB) 7.4.1-debian
> Copyright (C) 2012 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later 
> <http://gnu.org/licenses/gpl.html>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.  Type "show 
> copying"
> and "show warranty" for details.
> This GDB was configured as "arm-linux-gnueabihf".
> For bug reporting instructions, please see:
> <http://www.gnu.org/software/gdb/bugs/>...
> Reading symbols from /usr/local/bin/mmsbox...done.
> (gdb)  handle SIGILL nostop
> Signal        Stop    Print    Pass to program    Description
> SIGILL        No    Yes    Yes        Illegal instruction
> (gdb) run /usr/local/etc/mbuni/mbuni.conf
> Starting program: /usr/local/bin/mmsbox /usr/local/etc/mbuni/mbuni.conf
> [Thread debugging using libthread_db enabled]
> Using host libthread_db library 
> "/lib/arm-linux-gnueabihf/libthread_db.so.1".
> Program received signal SIGILL, Illegal instruction.
> Program received signal SIGILL, Illegal instruction.
> Program received signal SIGSEGV, Segmentation fault.
> 0xb6f0d954 in octstr_imm () from /usr/local/lib/libmmsbox.so.0
> (gdb) where
> #0  0xb6f0d954 in octstr_imm () from /usr/local/lib/libmmsbox.so.0
> #1  0xb6e065f8 in construct_linear_table () from 
> /usr/local/lib/libmms.so.0
> #2  0xb6e06dac in wsp_strings_init () from /usr/local/lib/libmms.so.0
> #3  0xb6deb9f8 in mms_strings_init () at mms_strings.c:216
> #4  0x0000a66c in main (argc=2, argv=0xbefffde4) at mmsbox.c:541
> (gdb)
> Removing the sigill handler is needed to get past loading openssl on 
> arm. I've tried a few times to get libmmsbox to build with debug 
> symbols to help get deeper into this but not got very far yet.
> I saw something similar mentioned in the user mailing list without a 
> solution:
> http://www.mail-archive.com/users@mbuni.org/msg02372.html
> Anybody got any suggestions?
> Thanks,
> Ben


Devel mailing list

Reply via email to