Yes, "dm-ploop" name looks better.

Reviewed-by: Pavel Tikhomirov <[email protected]>

On 11/20/25 01:26, Konstantin Khorenko wrote:
> Rename the ploop module to dm-ploop to match naming convention
> with other device mapper modules like dm-qcow2.
> 
> Add MODULE_ALIAS("ploop") to maintain backward compatibility,
> allowing the module to be loaded using the old name.
> 
> https://virtuozzo.atlassian.net/browse/VSTOR-119716
> Signed-off-by: Konstantin Khorenko <[email protected]>
> 
> Feature: dm-ploop: ploop target driver
> ---
>  drivers/md/Makefile          | 4 ++--
>  drivers/md/dm-ploop-target.c | 1 +
>  2 files changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/md/Makefile b/drivers/md/Makefile
> index 52a08618b2772..2b3212f0ce9fa 100644
> --- a/drivers/md/Makefile
> +++ b/drivers/md/Makefile
> @@ -31,7 +31,7 @@ md-mod-y    += md.o md-bitmap.o
>  raid456-y    += raid5.o raid5-cache.o raid5-ppl.o
>  linear-y       += md-linear.o
>  
> -ploop-y              += dm-ploop-target.o dm-ploop-map.o dm-ploop-cmd.o \
> +dm-ploop-y   += dm-ploop-target.o dm-ploop-map.o dm-ploop-cmd.o \
>                  dm-ploop-bat.o
>  push-backup-y        += dm-push-backup.o
>  dm-qcow2-y   += dm-qcow2-target.o dm-qcow2-map.o dm-qcow2-cmd.o
> @@ -116,7 +116,7 @@ ifeq ($(CONFIG_DM_AUDIT),y)
>  dm-mod-objs                  += dm-audit.o
>  endif
>  
> -obj-$(CONFIG_DM_PLOOP)               += ploop.o
> +obj-$(CONFIG_DM_PLOOP)               += dm-ploop.o
>  obj-$(CONFIG_DM_PUSH_BACKUP) += push-backup.o
>  obj-$(CONFIG_DM_TRACKING)    += dm-tracking.o
>  obj-$(CONFIG_DM_QCOW2)               += dm-qcow2.o
> diff --git a/drivers/md/dm-ploop-target.c b/drivers/md/dm-ploop-target.c
> index b122be1cd9632..6ab81a56707d6 100644
> --- a/drivers/md/dm-ploop-target.c
> +++ b/drivers/md/dm-ploop-target.c
> @@ -827,3 +827,4 @@ module_exit(dm_ploop_exit);
>  MODULE_AUTHOR("Kirill Tkhai <[email protected]>");
>  MODULE_LICENSE("GPL");
>  MODULE_DESCRIPTION("Virtuozzo Ploop Format Driver");
> +MODULE_ALIAS("ploop");

-- 
Best regards, Pavel Tikhomirov
Senior Software Developer, Virtuozzo.

_______________________________________________
Devel mailing list
[email protected]
https://lists.openvz.org/mailman/listinfo/devel

Reply via email to