I try to port riot to CC430F5137 using a panstamp board (
http://www.panstamp.com/product/197/ ). I didn't have any luck with the old
msp430debug package which i've found in the latest ubuntu. The first thing
I've tried to do is to get a simple UART example working, but when I've
tried to enable the interrupts with:
 __bis_SR_register(LPM0_bits + GIE);       // Enter LPM0, interrupts enabled
the whole thing freezed. I guess that some other kind of interrupt happens
all the time, but I haven't been able to debug it ( yet ).
So I've started using TI's / redhat's gcc compiler, and it worked just ok (
under windows ). So I've moved on to this compiler, which I've installed by
this tutorial:
I've tried to use chronos version for the first time, I've deleted all the
LCD headers, and modified stdio.h a little bit, so it doesn't looks for
these kind of files. The compilation worked previously with the obsolete
mspgcc, so that worked somewhat.
Now when I do BOARD=chronos make then it doesn't finds msp430-gcc. So I've
moved everything from opt/msp430-toolchain/bin ( the place where I've
installed the new TI mspgcc ) to bin, so it found the new mspgcc compiler.
Now it was missing the header file, I've modified the makefile.include so
it found it now. There were some missing stuff , but I've solved these
problems, but now I have this error:
as: unrecognized option '-mP'
I've did a verbose output with make -n, this came out:
I have found -mP but only with msp430-gcc, and there is no as program as
far as I know, so I doesn't really understand this.

My first question is: how to install this compiler properly, so that
whenever I use msp430-gcc then this new compiler will be called? I've also
tried to use the installer....sh file from ti, but it doesn't install it to
/bin or anything in the $PATH so I can't use it with the current makefiles.
The current solution is.....hmm kind of ugly and doesn't works :)

The second question: Should I use the obsolete ti compiler instead? What
causes this bug?

The third one is: What is this as / -mp thing?

Thanks for any help, and sorry for my ugly English.
devel mailing list

Reply via email to