> On 07/04/2022 10:36, Gabriel Moyano wrote:
> > diff --git a/cpukit/include/sys/timepps.h
> > b/cpukit/include/sys/timepps.h index 5703381ffa..a72579d5d7 100644
> > --- a/cpukit/include/sys/timepps.h
> > +++ b/cpukit/include/sys/timepps.h
> > @@ -149,6 +149,12 @@ struct mtx;
> >
> >   #define   PPSFLAG_MTX_SPIN        0x01    /* Driver mtx is MTX_SPIN type. 
> > */
> >
> > +#ifdef __rtems__
> > +struct pps_state;
> > +typedef int (*wait_event_func)(struct pps_state *pps, struct timespec
> > +timeout); typedef void (*wakeup_func)(struct pps_state *pps); #endif
> > +/* __rtems__ */
> > +
> >   struct pps_state {
> >     /* Capture information. */
> >     struct timehands *capth;
> > @@ -164,6 +170,11 @@ struct pps_state {
> >     int             ppscap;
> >     struct timecounter *ppstc;
> >     unsigned        ppscount[3];
> > +#ifdef __rtems__
> > +    wait_event_func wait_event;
> > +    wakeup_func wakeup;
> > +#endif /* __rtems__ */
> > +
> >     /*
> >      * The following fields are valid if the driver calls pps_init_abi().
> >      */
> 
> Why do we need the typedefs?

Just for clarity

> Please don't change the formatting.

Do you mean that wait_event should be waitevent?

> No changes outside the #ifdef __rtems__ markers please.

Sorry, could you point to the changes?

_______________________________________________
devel mailing list
devel@rtems.org
http://lists.rtems.org/mailman/listinfo/devel

Reply via email to