Second version of patches for enabling PPS API in RTEMS6. They have the following improvements: - Add function _Timecounter_Get_frequency() - Move hardpps to the _ namespace - Add a test (sptest/sppps01) for testing basic behaviour of struct pps_state - Add definition of atomic_load_int() as a relaxed atomic load - Remove the option for PPS_SYNC and add the #define
Gabriel Moyano (12): kern_ntptime.c: Disable freebsd features kern_ntptime.c: Add lmax() qmin() definitions timepps.h: Add missing include for atomic type kern_tc.c: Add definition of atomic_load_int() required by PPS API kern_tc.c: Replace FREEBSD event mechanism by adding pointers to function timecounter.h: Rename tc_getfrequency() to _Timecounter_Get_frequency() kern_tc.c: Add definitions required by PPS API kern_tc.c: Enable PPS API support kern_ntptime: Add define in order to remove warning timepps.h: PPS_SYNC defined by default timepps.h: Move hardpps to the _ namespace testsuites/sptests: Add sppps01 test cpukit/include/rtems/score/timecounter.h | 7 + cpukit/include/sys/timepps.h | 15 ++ cpukit/include/sys/timetc.h | 3 + cpukit/score/src/kern_ntptime.c | 19 ++- cpukit/score/src/kern_tc.c | 41 +++++- spec/build/testsuites/sptests/grp.yml | 2 + spec/build/testsuites/sptests/sppps01.yml | 19 +++ testsuites/sptests/sppps01/init.c | 160 ++++++++++++++++++++++ 8 files changed, 251 insertions(+), 15 deletions(-) create mode 100644 spec/build/testsuites/sptests/sppps01.yml create mode 100644 testsuites/sptests/sppps01/init.c -- 2.25.1 _______________________________________________ devel mailing list devel@rtems.org http://lists.rtems.org/mailman/listinfo/devel