On Thu, 1 Nov 2007, John Lumby wrote:
Thanks Marc.  I finally got the chance to build a new World based on latest
cvs 4.7 with your fixes and it does fix the problem - I've started X and
run Lotus Notes and shut down several times with two different WM's and no
problems while shutting down.

Does the log show any messages about unknown buffers?

I did notice one problem in one particular situation with this build but I
can't say I've ever tried it with the old build and I won't get a chance to
retry it for a while.

I was in a location where there was an external monitor sitting there and I
connected it to the external graphics socket on my IBM thinkpad T42p.  I
notice that,  instead of what I've seen on other machines, where pressing
the IBM Fn-F7 combination switches between the two monitors, with this
particular radeon driver and XFree86, the image is simultaneously displayed
on both monitors all the time and Fn-F7 has no effect.  Also (and this
surprises me but I don't really know much about multi-head displays) since
the external monitor has a smaller resolution than the laptop's monitor
which is 1600x1200, XFree86 displays just part of the T42 image on the
external (at the displayable resolution) and the mouse can pan that image -
although it's truly weird doing so since of course there's no panning on
the laptop monitor.  I don't know if this means anything at all to you.
I would much prefer to be able to run the image at the lower resolution on
the external and have nothing on the laptop under control of Fn-F7.  I have
tried fiddling with modes but it seems to ignore that.  But that is by the

This behaviour can be controlled with the driver's "MonitorLayout" option. See its man page. You could also generate a multihead configuration.

way.  I was running as described with this new build and then decided to
VT-switch with Ctl-Alt-F1 back to the first console (which runs a
framebuffer console with the fb radeon driver).  That worked.  But I then
tried to Ctl-Alt-F7 back to X - and the whole machine froze.  Nothing
revived it - Atl-Alt-Del, Ctl-Alt-Bspc, etc etc. had to reboot.  I have a
XFree86.0.log of that but there's nothing significant in it - no crash,
just the usual entries.

You would need to trace this to figure out where in RADEONEnterVT() or its callees the hang occurs. You would have to login remotely and run a static debuggable server under `gdb`.

I also noticed something strange concerning this XFree86 executable.  I
built it with the instructions you gave before for making a static exe:
 * Build a server that dynamically loads the modules by setting
 * this to YES.  This defaults to YES on most platforms.  A static server
 * can be built by setting this to NO.
#define DoLoadableServer    NO

but I'd say the exe that it built is not static - it's near the same size
as the old dynamic 4.6 one and only 1/3 the size of the static one based on
4.6 that I built before without fixes.
cd /usr/X11R6/bin;ls -lirt XFree86.dynload XFree86.statload XFree86;
200002 -rws--x--x    1 root     root      1968583 May  8  2006 XFree86.dynload
202526 -rwsr-xr-x    1 root     root      7351275 Sep  1 17:41 XFree86.statload
199934 -rws--x--x    1 root     root      2087673 Oct 30 10:24 XFree86

I guess it doesn't matter since it fixed the problem but did you expect

The log would say whether or not was generated by a loader server. Perhaps, DoLoadableServer wasn't picked up for some reason.

I also notice the permissions are different.  Is there a reason for that?

I have one other question - unrelated.   I see on the official XFree86
download site that pre-built binaries are available for up to (if I recall)
glibc-2.4 or 2.5, I forget which.  I was thinking of installing glibc-2.7
on one system.  Now I know how to make World I guess I can do that but was
wondering whether either one pre-built for an earlier glibc like 2.4 or 2.5
will run ok on a later glibc , or if not,

I don't know. You'd have to try it. The reason we generate binaries for different glibc versions is that there have been incompatibilities in the past. BTW, the host.def files used to generate binary distributions are in 'xc/programs/Xserver/hw/xfree86/etc/bisdist/'.

is XFree86 planning to build some at newer glibc levels?

Not to my knowledge. Speaking for myself, I don't have access to glibc 2.7 system that would allow me to generate binaries for it.

Do you want any more information or logs from either the freeze I mentioned
or from running ok with this build?

No.  Given it's a hard hang, I doubt the log will show anything.



|  Marc Aurele La France           |  work:   1-780-492-9310          |
|  Academic Information and        |  fax:    1-780-492-1729          |
|    Communications Technologies   |  email:  [EMAIL PROTECTED]         |
|  352 General Services Building   +----------------------------------+
|  University of Alberta           |                                  |
|  Edmonton, Alberta               |    Standard disclaimers apply    |
|  T6G 2H1                         |                                  |
|  CANADA                          |                                  |
XFree86 developer and VP.  ATI driver and X server internals.
Devel mailing list

Reply via email to