On 11/15/2010 08:37 AM, Dirk Brandewie wrote:
>>
>> To match other definitions in this file, this should be defined with
>> parentheses: #define KERNEL_DTB()
>>
>>> +   . = ALIGN(32);                                                  \
>>> +   VMLINUX_SYMBOL(__dtb_start) = .;                                \
>>> +   *(.dtb)                                                         \
>>
>> I wonder if .meminit.rodata.dtb be a better section name.  Could use
>> some input from more experienced kernel hackers here.  hpa, what say
>> you?
> 
> I will use what ever name seems reasonable,  It turns out that the sections 
> that 
> are named *.init.rodata are really in a R/W section :-( so that name is 
> really a 
> misnomer.  I will check with HPA on name again.
> 

I think they should be named *rodata* just to indicate that they should
eventually be moved to a readonly section.

        -hpa
_______________________________________________
devicetree-discuss mailing list
[email protected]
https://lists.ozlabs.org/listinfo/devicetree-discuss

Reply via email to