Hello Patrick, (I can't help but asking: you didn't happen to play the captain in a famous SciFi TV series, did you? :-) )
Patrick Stewart [2011-02-14 18:20 +0000]: > + if (g_udev_device_has_property (device->priv->d, > "UDISKS_FORCE_SYSTEM_INTERNAL")) This indeed come up quite a lot, and seems like a good idea. Would you mind if we renamed that just to "UDISKS_SYSTEM_INTERNAL", to be a bit better aligned with the other properties, and remove the rather redundant "force"? > + { > + if (g_udev_device_get_property_as_boolean (device->priv->d, > "UDISKS_FORCE_SYSTEM_INTERNAL")) > + { > + is_system_internal = TRUE; > + } > + else > + { > + is_system_internal = FALSE; > + } This can just be is_system_internal = g_udev_device_get_property_as_boolean (device->priv->d, "UDISKS_FORCE_SYSTEM_INTERNAL"); Thanks! Martin -- Martin Pitt | http://www.piware.de Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org) _______________________________________________ devkit-devel mailing list devkit-devel@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/devkit-devel