Hi devs,

Context: I had some quick discussion on this PR () and it led to discussing our 
current naming rule for  class property translations.

Right now our rule is:

I.e. for example:

I see at least 2 problems with this:

1) Problem 1: It’s not consistent with how we name other translations (we use 
lowercase everywhere and the prefix is the module name, not the space name). 
For example:

gardening.wiki.selectScripts=Sélectionnez les scripts de jardinage actifs
gardening.wiki.startJob=Démarrer le jardinage
gardening.wiki.start=Jardiner !
gardening.job.success=Terminé !
gardening.job.error=Une erreur est survenue, consultez les journaux pour plus 
Gardening.Code.GardeningScriptConfigurationClass_activeQueryScripts=Scripts de 
requête actifs

2) Problem 2: It’s fragile as it depends on the location of the class.

BTW just realizing that we may have broken lots of translations (and still are) 
when we moved code pages under the Code space… Did we check that?

FTR, the LT solves this by offering a translation prefix that can be specified 
by the dev.

WDYT? Do you agree with the problems? Do you see any other problem? Do you have 
any solution to propose?

Note: I’m not suggesting to change this right now but I’d like that we come to 
an agreement to what we’d like to have in the future.


Reply via email to