Hi Aamer

Yes, you are right. That's one of the controllers that wasn't moved over
yet, all you need to do is to annotate your controller with:

@ApiVersion( { Version.DEFAULT, Version.ALL } )

-- 
Morten Olav Hansen
Senior Engineer, DHIS 2
University of Oslo
http://www.dhis2.org

On Wed, Sep 21, 2016 at 12:23 AM, Aamer Mohammed <aam...@thoughtworks.com>
wrote:

> Hi Nicolay,
>
> We see that you have recently made changes in 2.25 settings-app to change
> the config.baseUrl from /api to /api/25
> As a result few of the apis mentioned below are not working as expected.
> We would like to know your plans on enabling api versioning for the
> metadata sync apis so that they can work fine with the new baseUrl as well.
>
>
> Thanks
> Aamer.
>
>
> On Tue, Sep 20, 2016 at 4:48 PM, Aamer Mohammed <aam...@thoughtworks.com>
> wrote:
>
>> Hi Lars/Morten,
>>
>> This is regarding the metadata sync feature which we have contributed to
>> DHIS recently. When we are using the setting-app from 2.25 development
>> branch (master), we see that versioned api calls are being made from the
>> app instead of the default api calls.
>> /api/25/metadata/versions
>> /api/25/metadata/version/create
>>
>> These apis are not yet redirected to the default behaviour. The
>> synchronization tab in settings-app is not working as a result. Please
>> suggest us on the behaviour of versioned apis and also to handle api
>> versioning for all the metadata sync apis.
>>
>>
>> Thanks
>> Aamer.
>>
>
>
_______________________________________________
Mailing list: https://launchpad.net/~dhis2-devs
Post to     : dhis2-devs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp

Reply via email to