Hi Ola,

Thank you very much for your advices. I am a DHIS2 beginner and I guess
that I am making some mistakes in the configuration and/or formula. I tried
yesterday and I get data in my pivot tables but not the data I need. In
only get "2" as I wrote it in my filter (see below). Let me answer to your
questions and explain the situation :-)

I am using "Event capture" as we did a one shot survey and we don't track
the patient.

*Program configuration:*

   - without registration
   - version: 4
   - Drop-down list
   - other field are empty or have the default configuration

*Program indicator set up *(I believe that here is the problem and that I
am making some mistakes with the formula):


   - I have one Data Element as follow : Are you satisfied with the
   gynecological service? Very satisfied (1), more or less (2) , and not at
   all (3) (these are the three responses possibles of my DE)
   - I wanted to create an indicator as follow: % of the respondents that
   say that they are "very satisfied" with the gynecological service.


   - Aggregation type: Average
   - Expression: I only selected my data element divided by the number of
   event count and then multiple by 100 : (#{qH1SRxSAoWI.AbdjW61ac8I} /
   V{event_count}) * 100
   - Filter I select my data element == 1 , so it is something like that
   : #{qH1SRxSAoWI.AbdjW61ac8I} == 2

I guess I am wrong in my formula. Any guidance, solution or advice?

Thank you again very much in advance for your support.
Julie


Julie Vanhamme



2017-05-18 9:28 GMT+02:00 Ola Hodne Titlestad <ol...@ifi.uio.no>:

> Hi Julie,
>
> Would be good if you could share some more details about your program
> configuration, including how you set up your program indicator.
>
> Are you using event capture (single event data) or tracker capture
> (multiple events and registration) for this use cases?
>
> When you say you can see the data in event reports, does that include
> aggregate values in the 'aggregated mode'?
>
> If I have trouble with my program indicators, I typically like to use
> pivot table app to debug. Try to add a few indicators that just count all
> events or all enrollments and display these at the same time. Will give you
> an indication of whether event analytics worked or not.
>
> Then for your program indicators where you struggle to get data, try to
> play with the different options of aggregation, e.g event count, enrollment
> count etc. You'll soon see if the issue is related to aggregation or the
> filter.
>
> Ola
> -------
>
> On 17 May 2017 17:48, "Em Le Hong" <em.hispviet...@gmail.com> wrote:
>
>> Hi,
>>
>> If everything is ok and your formula is correct but you can't see the
>> result. I guess you select both program indicator and data elements to show
>> in Pivot table or Event report.
>> Until now, DHIS2 only shows data for 1 selection data elements or program
>> indicator. If you only select program indicator to show, but you don't see
>> result, then you need to check your program indicator formula.
>>
>> Sincerely,
>>
>> On Wed, May 17, 2017 at 9:25 PM, Julie Vanhamme <juvha...@gmail.com>
>> wrote:
>>
>>> Hi Knut,
>>>
>>> Yes I did.
>>>
>>> Thank you very much in advance
>>> Julie
>>>
>>> Julie Vanhamme
>>>
>>>
>>>
>>> 2017-05-17 16:07 GMT+02:00 Knut Staring <knu...@gmail.com>:
>>>
>>>> Hi Julie,
>>>>
>>>> I am forwarding your question to the appropriate user mailing list.
>>>>
>>>> Just to make sure, did you run Analytics?
>>>>
>>>> Regards,
>>>> Knut
>>>> ---------- Forwarded message ----------
>>>> From: Julie <juvha...@gmail.com>
>>>> Date: Wed, May 17, 2017 at 3:44 PM
>>>> Subject: Difficulties with the Program Indicators
>>>> To: Knut Staring <knu...@gmail.com>
>>>>
>>>>
>>>> Hi,
>>>>
>>>> I am using the Event tracker of DHIS2 for a project.
>>>>
>>>> In a nutshell, I already set up the program and programs stages. I also
>>>> run the Analytics and I have will all the data needed in my program.
>>>> Indeed, while I am using the Event report with the data element (and not
>>>> the indicators), everything is fine and I can see the pivot tables with
>>>> the data.
>>>>
>>>> Now I am trying to create Indicators trough the program and everything
>>>> seemed ok (the formula,  etc.). Except that when I am trying to use the
>>>> indicator in a pivot table, the table appears but with no data inside.
>>>>
>>>> So what could be the problem with the indicators and how can I fix it?
>>>> Is it a problem of configuration? Formula? ...
>>>>
>>>> Many thanks.
>>>> Julie
>>>> --
>>>> This message was sent from Launchpad by
>>>> Julie (https://launchpad.net/~juvhamme)
>>>> using the "Contact this team's admins" link on the DHIS 2 Users team
>>>> page
>>>> (https://launchpad.net/~dhis2-users).
>>>> For more information see
>>>> https://help.launchpad.net/YourAccount/ContactingPeople
>>>>
>>>>
>>>>
>>>> --
>>>> Knut Staring
>>>> Dept. of Informatics, University of Oslo
>>>> Norway: +4791880522 <+47%20918%2080%20522>
>>>> Skype: knutstar
>>>> http://dhis2.org
>>>>
>>>
>>>
>>> _______________________________________________
>>> Mailing list: https://launchpad.net/~dhis2-users
>>> Post to     : dhis2-users@lists.launchpad.net
>>> Unsubscribe : https://launchpad.net/~dhis2-users
>>> More help   : https://help.launchpad.net/ListHelp
>>>
>>>
>>
>>
>> --
>> *Em Le Hong*
>> DHIS2 Implementation| *HISP Vietnam *
>> em.hispviet...@gmail.com | *Skype:* em.hispviet...@gmail.com
>>
>>
>>
>>
>>
>>
>> _______________________________________________
>> Mailing list: https://launchpad.net/~dhis2-users
>> Post to     : dhis2-users@lists.launchpad.net
>> Unsubscribe : https://launchpad.net/~dhis2-users
>> More help   : https://help.launchpad.net/ListHelp
>>
>>
_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to     : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help   : https://help.launchpad.net/ListHelp

Reply via email to