On 11/02/2013 02:25 PM, Joseph Rushton Wakeling wrote:
On Saturday, 2 November 2013 at 20:36:39 UTC, Andrei Alexandrescu wrote:
"Converse"? (Haven't read the section discussed.)

Could also work.  The range in question wraps an input range r and sets
front to return -r.front.

I spent considerable amount of time on those names. Like you, I am not happy with Inverse. :)

I wanted to say struct Negate and function negate(). But ! is the negation operator.

I like opposite better but the Wikipedia article calls it "additive inverse" so inverse is still acceptable, I guess? :)



Reply via email to