On Sunday, 17 November 2013 at 10:44:56 UTC, Moritz Maxeiner wrote:
On Saturday, 16 November 2013 at 12:49:05 UTC, Atila Neves wrote:
On Wednesday, 2 October 2013 at 15:14:08 UTC, Dicebot wrote:
Small Archy update:

1) dub has been just adopted into [community]

2) all three compiler phobos versions now provide 'd-runtime` and `d-stdlib` meta-dependencies

I think the gdc installation is missing files. I can compile simple programs easily enough, but importing core.runtime causes this:

/usr/include/dlang/gdc/4.8.2/gcc/backtrace.d:22: Error: module libbacktrace is in file 'gcc/libbacktrace.d' which cannot be read

And, sure enough, there is no such libbacktrace.d to be found. This is problematic since I can't compile anything with dub.

If you installed "gdc", did you install "libgphobos-devel"? Without the latter you have neither druntime, nor phobos (and as such not libbacktrace.d).

It's a known bug. This file should have been generated by some text templating engine. Dont remember where I posted the issue, but the maintainer is aware of the issue.

Reply via email to