El 29/11/13 20:37, ilya-stromberg ha escrit:
> On Friday, 29 November 2013 at 19:15:13 UTC, Jordi Sayol wrote:
>> New dub v0.9.20 deb packages available at:
>>
>> d-apt <http://d-apt.sourceforge.net/>
> 
> Thank you.
> BTW, it would be great to have packages for previous DMD versions. You 
> already support it for `libphobos2-nn` and almost for all other packages.
> 

"libphobos2-nn" and other packages ending with "-nn" contains the shared 
library necessary to run programs linked against them, so for this reason these 
packages have version on its name, allowing to install multiple versions of the 
same library.

Different case is "dmd" and development packages "-dev". Debian packaging 
system do not allow to install multiple versions of the same package at same 
time.

i.e. "dmd_2.064.2-0_amd64.deb" is newer version of "dmd_2.063.2-0_amd64.deb", 
and upgrades it.
same with "libphobos2-dev_2.064.2_amd64.deb", which replaces 
"libphobos2-dev_2.063.2_amd64.deb" by an upgrade.

To have multiple dmd versions on your system, you can use the Jacob Carlborg 
project <https://github.com/jacob-carlborg/dvm>

Regards,
-- 
Jordi Sayol

Reply via email to