On 2/14/14, 5:10, Daniel Murphy wrote:
"1100110" wrote in message news:tjgimnoqoflzrcrlw...@forum.dlang.org...
I'm offering a $50 bounty on this.
(Preferably Bitcoins, but I'll use bountysource if desired.)
I'd say just put it on bountysource, because then there's more chance
others will add to it.
I thought that would be best, unfortunately.
I don't think we'll ever please everyone here. All I'm really trying to
do by specifying the name is prevent some cutesy annoying name.
Has to be called -minimal
Dealbreaker. The description for the switch reads "prevents all use of
features which rely on druntime" and therefore the only reasonable
switch name is "-nodruntime" or a variation of that.
I'd be fine with the switch being name -nodruntime, and honestly I like
Has to fulfill Walter's original post. (listed below)
Has to split the separate parts into different flags as well as
-minimal(-nogc, -nomoduleinfo, etc. Naming is left to the implementer).
Make a enhancement report on bugzilla with the details.
I will as soon as I iron a few wrinkles. I need to figure out if
typeinfo should be a part of this as well.