Hey all,

I have been working on a lot of things for DSFML, namely getting it updated to 2.1(which is the most current official version). Some of these changes will break existing code in a couple of places, so I wanted to make an announcement before I started pushing the new code into the repo's master branch.


This announcement is mainly targeted at DUB users. Please be aware that it will update your local copy of the repo and that might start breaking things with out your realizing. To prevent this from happening, and to allow yourself to continue with your DSFML projects like nothing is happening, simply change your DSFML dependencies in your dub.json to use "~2.0" instead of "~master". I'll wait a couple of days to actually commit the code just in case.

I'm really excited about this upcoming release of the project as it improves the stability of the library and fixes many problems. As always, feel free to email me or open up issues on github if you have any problems with DSFML.

project: https://github.com/Jebbs/DSFML
email: dehaan.jerem...@gmail.com

Reply via email to