It doesn't seem to work anymore, even http://lint.travis-ci.org/ says I can't use "language: d".

Atila

On Thursday, 11 December 2014 at 04:50:42 UTC, Martin Nowak wrote:
Glad to announce that D support on Travis-CI was launched today.

http://blog.travis-ci.com/2014-12-10-community-driven-language-support-comes-to-travis-ci/

You can now get out-of-the-box continuous integration for your D projects on github. If you are already using dub, using Travis-CI is as simple as adding a 2 line .travis.yml file to your repo and toggling a switch on travis-ci.org.

language:d
sudo: false

You can also chose a specific compiler by adding a d: tag.

d: ldc-0.14.0

Build matrices are supported as well, so you can test your project against multiple compilers. Please only test as many compilers as you actually need!

d:
  - dmd-2.066.1
  - gdc-4.9.0
  - ldc-0.14.0

The following compilers were successfully tested.

dmd-2.064
dmd-2.065.0
dmd-2.066.1
gdc-4.8.2
gdc-4.9.0
ldc-0.13.0
ldc-0.14.0

Read the docs for more details http://docs.travis-ci.com/user/languages/d/.

And you can also have a look at these 2 libraries.

https://travis-ci.org/MartinNowak/hyphenate
https://travis-ci.com/MartinNowak/bloom

Happy testing
-Martin

Reply via email to