I still can't get 0.7.24. My config is:

"dependencies": {
"vibe-d": "0.7.24"
},

D:\code\httpApp>dub clean-caches

D:\code\httpApp>dub build
Fetching vibe-d 0.7.23 (getting selected version)...
Placing vibe-d 0.7.23 to C:\Users\bubenkov_di\AppData\Roaming\dub\packages\... Selected package vibe-d 0.7.23 does not match the dependency specification 0.7.2
4 in package httpapp. Need to "dub upgrade"?
Selected package libasync 0.7.5 does not match the dependency specification 0.7.
1 in package vibe-d. Need to "dub upgrade"?
Building vibe-d 0.7.23 configuration "libevent", build type debug.
Running dmd...
C:\Users\bubenkov_di\AppData\Roaming\dub\packages\vibe-d-0.7.23\source\vibe\core
\drivers\libevent2.d(631): Error: '_d_monitorenter' is not nothrow
C:\Users\bubenkov_di\AppData\Roaming\dub\packages\vibe-d-0.7.23\source\vibe\core
\drivers\libevent2.d(631): Error: '_d_monitorexit' is not nothrow
C:\Users\bubenkov_di\AppData\Roaming\dub\packages\vibe-d-0.7.23\source\vibe\core
\drivers\libevent2.d(622): Error: function 'vibe.core.drivers.libevent2.Libevent
2ManualEvent.emit' is nothrow yet may throw

Reply via email to