On Monday, 9 November 2015 at 12:28:09 UTC, FreeSlave wrote:


I tried to install rpm-package on Fedora 20 with rpm -i, but it gives me

error: Failed dependencies:
        glibc-devel(x86-32) is needed by dmd-2.069.0-0.x86_64
        libcurl(x86-32) is needed by dmd-2.069.0-0.x86_64

Why do package depends on 32-bit libraries? Was it always like that? I never installed dmd on Fedora before.

Yes, it was always like that.
To be able to generate 32-bit binaries, and dmd-64 can do that, these 32-bit packages are required.

Reply via email to