On Friday, 18 December 2015 at 10:41:13 UTC, Vadim Lopatin wrote:
On Thursday, 17 December 2015 at 08:27:05 UTC, ZombineDev wrote:

GDB support improvements: stack and local variables windows added.

This is quick progress! Awesome! I finally have some free time on my hands, so I deleted my workspace and tried to set things up following the How to hack on DlangIDE steps again. After doing that and trying to compile on Debug/Win32 I get output with a linker error:
Building Debug\dlangide.exe...
Microsoft (R) Incremental Linker Version 14.00.23026.0
Copyright (C) Microsoft Corporation.  All rights reserved.

LINK : fatal error LNK1104: Datei "Debug\dlangide.obj,Debug\dlangide.exe,Debug\dlangide.map,C:\Users\Administrator\Documents\DCode\dlangui\Debug\dlangui.lib+" kann nicht geƶffnet werden.
Building Debug\dlangide.exe failed!

The dlangui project builds correctly btw (it's the only one in the solution that does).

If I change to Debug/x64 I get a popup from VS telling me that it couldn't find the right project to launch since there are no startup projects set (even though I did set DlangIDE as startup project and it shows). If I explicitly tell it to build dlangide (right-click the project > build) I get another linker error telling me it cannot open "phobos64.lib". I do have phobos64.lib in the normal directory it is in after installation (ie windows/lib64), but for some reason it doesn't pick up on that. I even tried setting PATH directly to it, but that also didn't help.

I started up ProcessMonitor and looked at where it was searching for phobos64.lib and the results were pretty worrying:
C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\lib\amd64\phobos64.lib C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\lib\amd64\phobos64.lib C:\Program Files (x86)\Windows Kits\10\Lib\10.0.10150.0\ucrt\x64\phobos64.lib C:\Program Files (x86)\Windows Kits\10\Lib\10.0.10150.0\ucrt\x64\phobos64.lib C:\Program Files (x86)\Windows Kits\8.1\Lib\winv6.3\um\x64\phobos64.lib C:\Program Files (x86)\Windows Kits\8.1\Lib\winv6.3\um\x64\phobos64.lib

Where DCode\dlangide is obviously the path where I set things up. The rest seem to be things coming from automatic configuration VS has done at some point. I'm not sure how or where I can tell it to also look into my dmd installation paths.

Now instead of going for a proper fix I simply attempted copying the phobos64.lib to the dlangide directory just to see if this would get it to compile: Turns out it doesn't. When trying to compile like that, I get a popup saying

std.utf.UTFException@c:\s\d\rainers\phobos\std\utf.d(1109): Invalid UTF-8 sequence (at index 1)

Is this an ICE? Is my Visual D installation broken (I did reinstall Visual D a few times by now already)? I'm using dmd 2.069.2 which is the most recent version to my knowledge.

Pretty stumped about all of this and this looks a lot like something in my VS or VD setup is horribly broken (especially looking at the Win32 linker errors and the lack of properly configured search paths for phobos64.lib), but I'm not sure what exactly or how to go about fixing it/narrowing down the problem.

Any help in somehow getting this all to build would be much appreciated. Oh and of course "dub run" works just fine.

Reply via email to