I still believe it should be something more readable:

import std.stdio, std.conv : [ to, from ], std.algorithm : doSomething,
std.whatever;

On Thu, Feb 22, 2018 at 11:30 AM, psychoticRabboit via
Digitalmars-d-announce <digitalmars-d-announce@puremagic.com> wrote:

> On Thursday, 22 February 2018 at 09:42:47 UTC, Atila Neves wrote:
>
>>
>> I'm going to a) never write these imports and b) pretend this feature
>> doesn't exist.
>>
>> Atila
>>
>
> what about something like this then?
>
> import std.stdio; std.conv: to, from; std.algorithm: doSomething;
> std.whatever;
>
> just one simple rule; multiple imports on a line are seperated with ;
>
> surely the parser or whatever it's called, could work with that clean and
> simple solution.
>
>

Reply via email to