On 3/6/18 1:49 AM, Jonathan M Davis wrote:
Regardless, I doubt that the design of ranges is going to be changed at this
point given the amount of code that would break as a result, and these sort
of changes are not backwards compatible.
I sometimes think we would be better off to drop InputRange, and base
everything on the assumption that it can be copied (where isInputRange
is renamed to isForwardRange, and `save` goes away). Then you could use
@disable postblit to mimic what InputRange would have been.
I've never seen the point of having classes be ranges.