http://d.puremagic.com/issues/show_bug.cgi?id=2607

           Summary: Please consider building DMD agast and older version of
                    glibc
           Product: D
           Version: unspecified
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: DMD
        AssignedTo: bugzi...@digitalmars.com
        ReportedBy: ja...@spashett.com


DMD users have found that a recent version of glib is required to execute the
comiler. For example, DMD will not execute on redhat linux 2 as it requires a
newer glibc (Centos 2 does not need a license and is equivleant to redhat 2)

By linking with an older glibc forward compatability is obtained. I suggest
linking dmd against a version of glibc found in, for example centos 2 (redhat
EL 2) which is the oldest version that Red Hat support, and seems a reasonable
base requirement at this time.


-- 

Reply via email to