Summary: Inconsistent naming in TypeInfo derived classes
Most members of TypeInfo and derived classes are named simply, eg "next",
"value", "name". There are exceptions:
Also, TypeInfo_Pointer has its value type as "m_next", whereas TypeInfo_Array
has its value type as "value".
These are needless inconsistencies. I'd like to see them done away with.