http://d.puremagic.com/issues/show_bug.cgi?id=2963





--- Comment #4 from Mike Wynn <one_mad_al...@hotmail.com>  2009-05-16 09:14:49 
PDT ---
I've tried `sudo apt-get install lib32stdc++6` and `sudo apt-get install
libc6-dev-i368`  (the former I had but the latter was missing)
I now fail to find a compatible libgcc 
I have tried `sudo apt-get install lib32gcc1` but that is already installed.
(I tried apt-cache search for 'gcc' and 'lib32' so see if I could find a hint
...)

+ dmd -v -I~/bin/dmd/src/druntime/import -I~/bin/dmd/src/phobos
-L-L/home/mwynn/bin/dmd/linux/lib main.d
parse     main
semantic  main
import    object    (/home/mwynn/bin/dmd/src/druntime/import/object.di)
import    std.c.stdio    (/home/mwynn/bin/dmd/src/phobos/std/c/stdio.d)
import    core.stdc.stdio   
(/home/mwynn/bin/dmd/src/druntime/import/core/stdc/stdio.d)
import    core.stdc.config   
(/home/mwynn/bin/dmd/src/druntime/import/core/stdc/config.d)
import    core.stdc.stddef   
(/home/mwynn/bin/dmd/src/druntime/import/core/stdc/stddef.d)
import    core.stdc.stdarg   
(/home/mwynn/bin/dmd/src/druntime/import/core/stdc/stdarg.d)
semantic2 main
semantic3 main
code      main
function  main
gcc main.o -o main -m32 -Xlinker -L/home/mwynn/bin/dmd/linux/lib -lphobos2
-lpthread -lm 
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.2.4/libgcc.a
when searching for -lgcc
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.2.4/libgcc.a
when searching for -lgcc
/usr/bin/ld: cannot find -lgcc
collect2: ld returned 1 exit status

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------

Reply via email to