http://d.puremagic.com/issues/show_bug.cgi?id=3170





--- Comment #11 from Don <clugd...@yahoo.com.au>  2009-07-16 01:02:36 PDT ---

> > For one thing, it means that any search for "1.x bugs" becomes invalid every
> > time there's a new compiler version!
> 
> How do you work that out?

Because you can't do a search for "1.x bugs", you can only search for "1.0 +
1.01+ 1.02+... + 1.045". Then 1.046 gets added, and it's not in your search.
I'm getting really sick of it.


> >> - if a bug exists in both 1.x and 2.x, the 1.x version is set
> > 
> > That used to work well, when the compilers were almost identical. We're now
> > getting a lot of bugs which are 1.x only.
> 
> Like what?

>From my list of unpatched ICE bugs, there are 9 which are D1-specific:
1144, 1934, 2229, 2687, 1897, 3160, 1787, 2080, 2851.
There are 9 which are D2-specific.
There are another 7 which are common to both (this number is artificially low,
since there are the ones I put most effort into).
The difference in the compiler internals is increasing, so some patches which
work for D2 don't work for D1, and vice versa.





> 
> > Adding keywords is extremely helpful.
> 
> Agreed.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------

Reply via email to